aboutsummaryrefslogtreecommitdiff
path: root/backend/CMakeLists.txt
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2017-07-11 20:15:28 -0400
committerGitHub <noreply@github.com>2017-07-11 20:15:28 -0400
commit85805da021006697c85489c3e30717c2b807441c (patch)
treeae4a0221b8747579314262b59ff01bec2a32d3b8 /backend/CMakeLists.txt
parent8189c64d7f07a756abf5a6189719f02b2f1af967 (diff)
parente54b1eded4fc44e6f3d22af2f16d5e055dfd0045 (diff)
Merge pull request #27 from ascent12/meson
[Proposal] Use the Meson build system
Diffstat (limited to 'backend/CMakeLists.txt')
-rw-r--r--backend/CMakeLists.txt42
1 files changed, 0 insertions, 42 deletions
diff --git a/backend/CMakeLists.txt b/backend/CMakeLists.txt
deleted file mode 100644
index 5486b302..00000000
--- a/backend/CMakeLists.txt
+++ /dev/null
@@ -1,42 +0,0 @@
-include_directories(
- ${PROTOCOLS_INCLUDE_DIRS}
- ${WAYLAND_INCLUDE_DIR}
- ${DRM_INCLUDE_DIRS}
- ${LIBINPUT_INCLUDE_DIRS}
-)
-
-add_library(wlr-backend
- wayland/backend.c
- wayland/registry.c
- wayland/wl_seat.c
- wayland/output.c
- drm/backend.c
- drm/drm.c
-
- libinput/backend.c
- libinput/events.c
- libinput/keyboard.c
- libinput/pointer.c
- libinput/touch.c
- libinput/tablet_tool.c
- libinput/tablet_pad.c
-
- multi/backend.c
- backend.c
- egl.c
- udev.c
-)
-
-target_link_libraries(wlr-backend
- wlr-util
- wlr-types
- ${WAYLAND_LIBRARIES}
- ${DRM_LIBRARIES}
- ${GBM_LIBRARIES}
- ${GLESv2_LIBRARIES}
- ${EGL_LIBRARIES}
- ${SYSTEMD_LIBRARIES}
- ${UDEV_LIBRARIES}
- ${LIBINPUT_LIBRARIES}
- ${GBM_LIBRARIES}
-)