aboutsummaryrefslogtreecommitdiff
path: root/backend/CMakeLists.txt
diff options
context:
space:
mode:
authornyorain <nyorain@gmail.com>2017-06-19 17:49:26 +0200
committernyorain <nyorain@gmail.com>2017-06-19 17:49:26 +0200
commit41a477375cf5fc2cfafc97fb6d98e4e3457dfa62 (patch)
tree93e318287fb70b21dd0f5d7f90551810fa85a7dd /backend/CMakeLists.txt
parent904739c40596cb4e9e9d48c89b1d864051237441 (diff)
parent7e038a6110501a51e7f3d3366e8bc54a02766f22 (diff)
Merge branch 'libinput' into wayland-backend
Diffstat (limited to 'backend/CMakeLists.txt')
-rw-r--r--backend/CMakeLists.txt13
1 files changed, 12 insertions, 1 deletions
diff --git a/backend/CMakeLists.txt b/backend/CMakeLists.txt
index a5669307..490fad71 100644
--- a/backend/CMakeLists.txt
+++ b/backend/CMakeLists.txt
@@ -2,6 +2,7 @@ include_directories(
${PROTOCOLS_INCLUDE_DIRS}
${WAYLAND_INCLUDE_DIR}
${DRM_INCLUDE_DIRS}
+ ${LIBINPUT_INCLUDE_DIRS}
)
add_library(wlr-backend
@@ -11,9 +12,18 @@ add_library(wlr-backend
wayland/wl_output.c
drm/backend.c
drm/drm.c
- udev.c
+
+ libinput/backend.c
+ libinput/events.c
+ libinput/keyboard.c
+ libinput/pointer.c
+ libinput/touch.c
+ libinput/tablet_tool.c
+
+ multi/backend.c
backend.c
egl.c
+ udev.c
)
target_link_libraries(wlr-backend
@@ -26,5 +36,6 @@ target_link_libraries(wlr-backend
${EGL_LIBRARIES}
${SYSTEMD_LIBRARIES}
${UDEV_LIBRARIES}
+ ${LIBINPUT_LIBRARIES}
${GBM_LIBRARIES}
)