aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2017-05-10 10:37:29 -0400
committerGitHub <noreply@github.com>2017-05-10 10:37:29 -0400
commitc436e76240ab190a07afcd961ca2dd279af72968 (patch)
treeaab4f835e5341cd44b5937e0cd0dbb012c2369e8 /CMakeLists.txt
parent1aed98730194aa80b5954ae1d6370162041b56e2 (diff)
parent42878b45a1dba582feb5ec75762d66ede51fdc98 (diff)
Merge pull request #2 from ascent12/master
DRM backend + Session interface + EGL
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index dd4d9969..616a8911 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -48,9 +48,10 @@ find_package(WaylandProtocols REQUIRED)
find_package(EGL REQUIRED)
find_package(GLESv2 REQUIRED)
find_package(DRM REQUIRED)
+find_package(GBM REQUIRED)
find_package(LibInput REQUIRED)
-find_package(Udev)
-find_package(Dbus)
+find_package(Udev REQUIRED)
+find_package(Systemd)
include(Wayland)
include(Manpage)
@@ -60,5 +61,6 @@ include_directories(include)
add_subdirectory(backend)
add_subdirectory(common)
add_subdirectory(wayland)
+add_subdirectory(session)
add_subdirectory(example)