aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAleix Pol <aleixpol@kde.org>2020-10-15 15:49:41 +0200
committerAleix Pol <aleixpol@kde.org>2021-04-30 14:26:50 +0200
commit032a0bdc9b293bfa04a691f92a85ab88d4907447 (patch)
tree57d72782cbf69bc1142ae36530f62ac8ee4648b7 /meson.build
parent5381e39bab9e74b9f1dc3ceb9d517eeac13a7797 (diff)
Include a new xdg_activation protocol
Signed-off-by: Aleix Pol Gonzalez <aleixpol@kde.org> Reviewed-by: David Edmundson <davidedmundson@kde.org> Reviewed-by: Simon Ser <contact@emersion.fr> Reviewed-by: Jonas Ã…dahl <jadahl@gmail.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 1f30157..c6dd104 100644
--- a/meson.build
+++ b/meson.build
@@ -37,12 +37,24 @@ unstable_protocols = {
'xwayland-keyboard-grab': ['v1'],
}
+staging_protocols = {
+ 'xdg-activation': ['v1'],
+}
+
protocol_files = []
foreach name : stable_protocols
protocol_files += ['stable/@0@/@0@.xml'.format(name)]
endforeach
+foreach name : staging_protocols.keys()
+ foreach version : staging_protocols.get(name)
+ protocol_files += [
+ 'staging/@0@/@0@-@1@.xml'.format(name, version)
+ ]
+ endforeach
+endforeach
+
foreach name : unstable_protocols.keys()
foreach version : unstable_protocols.get(name)
protocol_files += [