aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJonas Ådahl <jadahl@gmail.com>2015-10-21 11:59:01 +0800
committerJonas Ådahl <jadahl@gmail.com>2016-02-16 17:17:49 +0800
commit162619d605982600816edce712ec5229cfe4ea6f (patch)
tree574b73459871a63f28e4cab72306422667b4c6fd /Makefile.am
parenta956c73e4eb241e8582b74f6089c022500013041 (diff)
Introduce pointer locking and confinement protocol
This patch introduces a new protocol for locking and confining a pointer. It consists of a new global object with two requests; one for locking the surface to a position, one for confining the pointer to a given region. Signed-off-by: Jonas Ådahl <jadahl@gmail.com> Reviewed-by: Peter Hutterer <peter.hutterer@who-t.net> Reviewed-by: Derek Foreman <derekf@osg.samsung.com> Reviewed-by: Reviewed-by: Daniel Stone <daniels@collabora.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 0389637..57d0023 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,6 +6,7 @@ unstable_protocols = \
unstable/input-method/input-method-unstable-v1.xml \
unstable/xdg-shell/xdg-shell-unstable-v5.xml \
unstable/relative-pointer/relative-pointer-unstable-v1.xml \
+ unstable/pointer-constraints/pointer-constraints-unstable-v1.xml \
$(NULL)
stable_protocols = \