aboutsummaryrefslogtreecommitdiff
path: root/swaynag/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'swaynag/meson.build')
-rw-r--r--swaynag/meson.build20
1 files changed, 20 insertions, 0 deletions
diff --git a/swaynag/meson.build b/swaynag/meson.build
new file mode 100644
index 00000000..6492e4dc
--- /dev/null
+++ b/swaynag/meson.build
@@ -0,0 +1,20 @@
+executable(
+ 'swaynag', [
+ 'main.c',
+ 'nagbar.c',
+ 'render.c',
+ ],
+ include_directories: [sway_inc],
+ dependencies: [
+ cairo,
+ client_protos,
+ gdk_pixbuf,
+ pango,
+ pangocairo,
+ wayland_client,
+ wayland_cursor,
+ wlroots,
+ ],
+ link_with: [lib_sway_common, lib_sway_client],
+ install: true
+)