aboutsummaryrefslogtreecommitdiff
path: root/swaymsg/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'swaymsg/CMakeLists.txt')
-rw-r--r--swaymsg/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/swaymsg/CMakeLists.txt b/swaymsg/CMakeLists.txt
new file mode 100644
index 00000000..79af0f3e
--- /dev/null
+++ b/swaymsg/CMakeLists.txt
@@ -0,0 +1,16 @@
+project(swaymsg)
+
+set(CMAKE_CURRENT_BINARY_DIR ${CMAKE_CURRENT_BINARY_DIR}/../bin/)
+
+FILE(GLOB sources ${PROJECT_SOURCE_DIR}/*.c)
+FILE(GLOB common ${PROJECT_SOURCE_DIR}/../common/*.c)
+
+add_executable(swaymsg
+ ${sources}
+ ${common}
+)
+
+install(
+ TARGETS swaymsg
+ RUNTIME DESTINATION bin
+ COMPONENT runtime)