aboutsummaryrefslogtreecommitdiff
path: root/swaylock/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'swaylock/meson.build')
-rw-r--r--swaylock/meson.build18
1 files changed, 18 insertions, 0 deletions
diff --git a/swaylock/meson.build b/swaylock/meson.build
new file mode 100644
index 00000000..5b886ded
--- /dev/null
+++ b/swaylock/meson.build
@@ -0,0 +1,18 @@
+executable(
+ 'swaylock',
+ 'main.c',
+ include_directories: [sway_inc],
+ dependencies: [
+ cairo,
+ client_protos,
+ gdk_pixbuf,
+ libpam,
+ math,
+ pango,
+ pangocairo,
+ wayland_client,
+ wlroots,
+ ],
+ link_with: [lib_sway_common, lib_sway_client],
+ install: true
+)