aboutsummaryrefslogtreecommitdiff
path: root/swayidle/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'swayidle/meson.build')
-rw-r--r--swayidle/meson.build27
1 files changed, 0 insertions, 27 deletions
diff --git a/swayidle/meson.build b/swayidle/meson.build
deleted file mode 100644
index 79d2c5c4..00000000
--- a/swayidle/meson.build
+++ /dev/null
@@ -1,27 +0,0 @@
-threads = dependency('threads')
-
-swayidle_deps = [
- client_protos,
- pixman,
- wayland_client,
- wayland_server,
- wlroots,
-]
-
-if systemd.found()
- swayidle_deps += systemd
-endif
-if elogind.found()
- swayidle_deps += elogind
-endif
-
-executable(
- 'swayidle', [
- 'main.c',
- ],
- include_directories: [sway_inc],
- dependencies: swayidle_deps,
- link_with: [lib_sway_common, lib_sway_client],
- install_rpath : rpathdir,
- install: true
-)