aboutsummaryrefslogtreecommitdiff
path: root/swayidle/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'swayidle/meson.build')
-rw-r--r--swayidle/meson.build24
1 files changed, 16 insertions, 8 deletions
diff --git a/swayidle/meson.build b/swayidle/meson.build
index 6c3ac119..79d2c5c4 100644
--- a/swayidle/meson.build
+++ b/swayidle/meson.build
@@ -1,18 +1,26 @@
threads = dependency('threads')
+swayidle_deps = [
+ client_protos,
+ pixman,
+ wayland_client,
+ wayland_server,
+ wlroots,
+]
+
+if systemd.found()
+ swayidle_deps += systemd
+endif
+if elogind.found()
+ swayidle_deps += elogind
+endif
+
executable(
'swayidle', [
'main.c',
],
include_directories: [sway_inc],
- dependencies: [
- client_protos,
- pixman,
- wayland_client,
- wayland_server,
- wlroots,
- swayidle_deps,
- ],
+ dependencies: swayidle_deps,
link_with: [lib_sway_common, lib_sway_client],
install_rpath : rpathdir,
install: true