aboutsummaryrefslogtreecommitdiff
path: root/swaygrab/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'swaygrab/CMakeLists.txt')
-rw-r--r--swaygrab/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/swaygrab/CMakeLists.txt b/swaygrab/CMakeLists.txt
new file mode 100644
index 00000000..5b47a694
--- /dev/null
+++ b/swaygrab/CMakeLists.txt
@@ -0,0 +1,16 @@
+project(swaygrab)
+
+set(CMAKE_CURRENT_BINARY_DIR ${CMAKE_CURRENT_BINARY_DIR}/../bin/)
+
+FILE(GLOB sources ${PROJECT_SOURCE_DIR}/*.c)
+FILE(GLOB common ${PROJECT_SOURCE_DIR}/../common/*.c)
+
+add_executable(swaygrab
+ ${sources}
+ ${common}
+)
+
+install(
+ TARGETS swaygrab
+ RUNTIME DESTINATION bin
+ COMPONENT runtime)