aboutsummaryrefslogtreecommitdiff
path: root/swaybg/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'swaybg/CMakeLists.txt')
-rw-r--r--swaybg/CMakeLists.txt11
1 files changed, 9 insertions, 2 deletions
diff --git a/swaybg/CMakeLists.txt b/swaybg/CMakeLists.txt
index 4dc961ff..68098370 100644
--- a/swaybg/CMakeLists.txt
+++ b/swaybg/CMakeLists.txt
@@ -3,7 +3,6 @@ include_directories(
${WAYLAND_CLIENT_INCLUDE_DIR}
${CAIRO_INCLUDE_DIRS}
${PANGO_INCLUDE_DIRS}
- ${GDK_PIXBUF_INCLUDE_DIRS}
)
add_executable(swaybg
@@ -17,10 +16,18 @@ target_link_libraries(swaybg
${WAYLAND_CURSOR_LIBRARIES}
${CAIRO_LIBRARIES}
${PANGO_LIBRARIES}
- ${GDK_PIXBUF_LIBRARIES}
m
)
+if (WITH_GDK_PIXBUF)
+ include_directories(
+ ${GDK_PIXBUF_INCLUDE_DIRS}
+ )
+ target_link_libraries(swaybg
+ ${GDK_PIXBUF_LIBRARIES}
+ )
+endif()
+
install(
TARGETS swaybg
RUNTIME