aboutsummaryrefslogtreecommitdiff
path: root/swaybg/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'swaybg/CMakeLists.txt')
-rw-r--r--swaybg/CMakeLists.txt37
1 files changed, 0 insertions, 37 deletions
diff --git a/swaybg/CMakeLists.txt b/swaybg/CMakeLists.txt
deleted file mode 100644
index f8cad404..00000000
--- a/swaybg/CMakeLists.txt
+++ /dev/null
@@ -1,37 +0,0 @@
-include_directories(
- ${PROTOCOLS_INCLUDE_DIRS}
- ${WAYLAND_INCLUDE_DIR}
- ${CAIRO_INCLUDE_DIRS}
- ${PANGO_INCLUDE_DIRS}
- ${XKBCOMMON_INCLUDE_DIRS}
-)
-
-add_executable(swaybg
- main.c
-)
-
-target_link_libraries(swaybg
- sway-common
- sway-wayland
- ${WAYLAND_CLIENT_LIBRARIES}
- ${WAYLAND_CURSOR_LIBRARIES}
- ${CAIRO_LIBRARIES}
- ${PANGO_LIBRARIES}
- m
-)
-
-if (WITH_GDK_PIXBUF)
- include_directories(
- ${GDK_PIXBUF_INCLUDE_DIRS}
- )
- target_link_libraries(swaybg
- ${GDK_PIXBUF_LIBRARIES}
- )
-endif()
-
-install(
- TARGETS swaybg
- RUNTIME
- DESTINATION bin
- COMPONENT runtime
-)