aboutsummaryrefslogtreecommitdiff
path: root/swaybg/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'swaybg/CMakeLists.txt')
-rw-r--r--swaybg/CMakeLists.txt13
1 files changed, 5 insertions, 8 deletions
diff --git a/swaybg/CMakeLists.txt b/swaybg/CMakeLists.txt
index 9351441a..1ad43324 100644
--- a/swaybg/CMakeLists.txt
+++ b/swaybg/CMakeLists.txt
@@ -7,9 +7,7 @@ find_package(Pango REQUIRED)
include(Wayland)
WAYLAND_ADD_PROTOCOL_CLIENT(proto-xdg-shell "xdg-shell.xml" xdg-shell)
-set(CMAKE_RUNTIME_OUTPUT_DIRECTORY "../bin/")
include_directories(
- ${CMAKE_CURRENT_SOURCE_DIR}/../include
${WAYLAND_CLIENT_INCLUDE_DIR}
${CAIRO_INCLUDE_DIRS}
${PANGO_INCLUDE_DIRS}
@@ -17,7 +15,6 @@ include_directories(
FILE(GLOB sources ${PROJECT_SOURCE_DIR}/*.c)
FILE(GLOB wl_sources ${PROJECT_SOURCE_DIR}/../wayland/*.c)
-FILE(GLOB common ${PROJECT_SOURCE_DIR}/../common/*.c)
add_executable(swaybg
${sources}
@@ -25,9 +22,9 @@ add_executable(swaybg
${common}
)
-TARGET_LINK_LIBRARIES(swaybg ${WAYLAND_CLIENT_LIBRARIES} ${CAIRO_LIBRARIES} ${PANGO_LIBRARIES})
+TARGET_LINK_LIBRARIES(swaybg ${WAYLAND_CLIENT_LIBRARIES} ${CAIRO_LIBRARIES} ${PANGO_LIBRARIES} sway_common)
-INSTALL(
- TARGETS swaybg
- RUNTIME DESTINATION bin
-)
+install(
+ TARGETS swaybg
+ RUNTIME DESTINATION bin
+ COMPONENT runtime)