aboutsummaryrefslogtreecommitdiff
path: root/swaybar/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'swaybar/meson.build')
-rw-r--r--swaybar/meson.build28
1 files changed, 28 insertions, 0 deletions
diff --git a/swaybar/meson.build b/swaybar/meson.build
new file mode 100644
index 00000000..d65edb11
--- /dev/null
+++ b/swaybar/meson.build
@@ -0,0 +1,28 @@
+executable(
+ 'swaybar', [
+ 'bar.c',
+ 'config.c',
+ 'event_loop.c',
+ 'i3bar.c',
+ 'ipc.c',
+ 'main.c',
+ 'render.c',
+ 'status_line.c',
+ ],
+ include_directories: [sway_inc],
+ dependencies: [
+ cairo,
+ client_protos,
+ gdk_pixbuf,
+ jsonc,
+ math,
+ pango,
+ pangocairo,
+ rt,
+ wayland_client,
+ wayland_cursor,
+ wlroots,
+ ],
+ link_with: [lib_sway_common, lib_sway_client],
+ install: true
+)