aboutsummaryrefslogtreecommitdiff
path: root/swaybar/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'swaybar/CMakeLists.txt')
-rw-r--r--swaybar/CMakeLists.txt44
1 files changed, 22 insertions, 22 deletions
diff --git a/swaybar/CMakeLists.txt b/swaybar/CMakeLists.txt
index b4ce9e7b..1b68fd3e 100644
--- a/swaybar/CMakeLists.txt
+++ b/swaybar/CMakeLists.txt
@@ -7,19 +7,19 @@ find_package(Pango REQUIRED)
include(Wayland)
set(CMAKE_CURRENT_BINARY_DIR ${CMAKE_CURRENT_BINARY_DIR}/../bin/)
WAYLAND_ADD_PROTOCOL_CLIENT(proto-xdg-shell
- "${PROJECT_SOURCE_DIR}/../protocols/xdg-shell.xml"
- xdg-shell
+ "${PROJECT_SOURCE_DIR}/../protocols/xdg-shell.xml"
+ xdg-shell
)
WAYLAND_ADD_PROTOCOL_CLIENT(proto-desktop-shell
- "${PROJECT_SOURCE_DIR}/../protocols/desktop-shell.xml"
- desktop-shell
+ "${PROJECT_SOURCE_DIR}/../protocols/desktop-shell.xml"
+ desktop-shell
)
include_directories(
- ${WAYLAND_CLIENT_INCLUDE_DIR}
- ${CAIRO_INCLUDE_DIRS}
- ${PANGO_INCLUDE_DIRS}
- ${CMAKE_CURRENT_BINARY_DIR}
+ ${WAYLAND_CLIENT_INCLUDE_DIR}
+ ${CAIRO_INCLUDE_DIRS}
+ ${PANGO_INCLUDE_DIRS}
+ ${CMAKE_CURRENT_BINARY_DIR}
)
file(GLOB sources ${PROJECT_SOURCE_DIR}/*.c)
@@ -27,24 +27,24 @@ file(GLOB common ${PROJECT_SOURCE_DIR}/../common/*.c)
file(GLOB wl_sources ${PROJECT_SOURCE_DIR}/../wayland/*.c)
add_executable(swaybar
- ${sources}
- ${wl_sources}
- ${common}
- ${proto-xdg-shell}
- ${proto-desktop-shell}
+ ${sources}
+ ${wl_sources}
+ ${common}
+ ${proto-xdg-shell}
+ ${proto-desktop-shell}
)
target_link_libraries(swaybar
- ${WAYLAND_CLIENT_LIBRARIES}
- ${WAYLAND_CURSOR_LIBRARIES}
- ${CAIRO_LIBRARIES}
- ${PANGO_LIBRARIES}
- m
+ ${WAYLAND_CLIENT_LIBRARIES}
+ ${WAYLAND_CURSOR_LIBRARIES}
+ ${CAIRO_LIBRARIES}
+ ${PANGO_LIBRARIES}
+ m
)
install(
- TARGETS swaybar
- RUNTIME
- DESTINATION bin
- COMPONENT runtime
+ TARGETS swaybar
+ RUNTIME
+ DESTINATION bin
+ COMPONENT runtime
)