aboutsummaryrefslogtreecommitdiff
path: root/sway/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'sway/meson.build')
-rw-r--r--sway/meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/sway/meson.build b/sway/meson.build
index 9ff3f05f..30c848e2 100644
--- a/sway/meson.build
+++ b/sway/meson.build
@@ -7,11 +7,14 @@ sway_sources = files(
'debug-tree.c',
'ipc-json.c',
'ipc-server.c',
+ 'scratchpad.c',
'security.c',
'desktop/desktop.c',
+ 'desktop/idle_inhibit_v1.c',
'desktop/layer_shell.c',
'desktop/output.c',
+ 'desktop/render.c',
'desktop/transaction.c',
'desktop/xdg_shell_v6.c',
'desktop/xdg_shell.c',
@@ -33,16 +36,20 @@ sway_sources = files(
'commands/border.c',
'commands/client.c',
'commands/default_border.c',
+ 'commands/default_floating_border.c',
'commands/default_orientation.c',
'commands/exit.c',
'commands/exec.c',
'commands/exec_always.c',
'commands/floating.c',
+ 'commands/floating_minmax_size.c',
+ 'commands/floating_modifier.c',
'commands/focus.c',
'commands/focus_follows_mouse.c',
'commands/focus_wrapping.c',
'commands/font.c',
'commands/for_window.c',
+ 'commands/force_display_urgency_hint.c',
'commands/force_focus_wrapping.c',
'commands/fullscreen.c',
'commands/gaps.c',
@@ -56,10 +63,12 @@ sway_sources = files(
'commands/mode.c',
'commands/mouse_warping.c',
'commands/move.c',
+ 'commands/no_focus.c',
'commands/output.c',
'commands/reload.c',
'commands/rename.c',
'commands/resize.c',
+ 'commands/scratchpad.c',
'commands/seat.c',
'commands/seat/attach.c',
'commands/seat/cursor.c',
@@ -73,6 +82,7 @@ sway_sources = files(
'commands/swap.c',
'commands/title_format.c',
'commands/unmark.c',
+ 'commands/urgent.c',
'commands/workspace.c',
'commands/workspace_layout.c',
'commands/ws_auto_back_and_forth.c',
@@ -115,8 +125,10 @@ sway_sources = files(
'commands/input/pointer_accel.c',
'commands/input/repeat_delay.c',
'commands/input/repeat_rate.c',
+ 'commands/input/scroll_button.c',
'commands/input/scroll_method.c',
'commands/input/tap.c',
+ 'commands/input/tap_button_map.c',
'commands/input/xkb_layout.c',
'commands/input/xkb_model.c',
'commands/input/xkb_options.c',