aboutsummaryrefslogtreecommitdiff
path: root/sway/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'sway/meson.build')
-rw-r--r--sway/meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/sway/meson.build b/sway/meson.build
index 30ec166b..80ccc01d 100644
--- a/sway/meson.build
+++ b/sway/meson.build
@@ -10,6 +10,7 @@ sway_sources = files(
'commands/exit.c',
'commands/exec.c',
'commands/exec_always.c',
+ 'commands/kill.c',
'commands/include.c',
'commands/input.c',
'commands/seat.c',
@@ -37,6 +38,7 @@ sway_sources = files(
'config/output.c',
'config/seat.c',
'config/input.c',
+ 'criteria.c',
'ipc-json.c',
'ipc-server.c',
'desktop/output.c',
@@ -46,10 +48,12 @@ sway_sources = files(
'security.c',
'tree/container.c',
'tree/layout.c',
+ 'tree/view.c',
'tree/workspace.c',
)
sway_deps = [
+ pcre,
pixman,
wayland_server,
jsonc,