aboutsummaryrefslogtreecommitdiff
path: root/sway/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'sway/meson.build')
-rw-r--r--sway/meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/sway/meson.build b/sway/meson.build
index 2a3c5b5e..00ebcb40 100644
--- a/sway/meson.build
+++ b/sway/meson.build
@@ -79,6 +79,7 @@ sway_sources = files(
'commands/seat/fallback.c',
'commands/set.c',
'commands/show_marks.c',
+ 'commands/smart_borders.c',
'commands/smart_gaps.c',
'commands/split.c',
'commands/sticky.c',
@@ -120,6 +121,7 @@ sway_sources = files(
'commands/input/accel_profile.c',
'commands/input/click_method.c',
+ 'commands/input/drag.c',
'commands/input/drag_lock.c',
'commands/input/dwt.c',
'commands/input/events.c',
@@ -165,7 +167,6 @@ sway_deps = [
cairo,
gdk_pixbuf,
jsonc,
- libcap,
libinput,
math,
pango,
@@ -188,5 +189,6 @@ executable(
include_directories: [sway_inc],
dependencies: sway_deps,
link_with: [lib_sway_common],
+ install_rpath : rpathdir,
install: true
)