aboutsummaryrefslogtreecommitdiff
path: root/sway/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'sway/CMakeLists.txt')
-rw-r--r--sway/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/sway/CMakeLists.txt b/sway/CMakeLists.txt
index 23829dc3..f7cc88ab 100644
--- a/sway/CMakeLists.txt
+++ b/sway/CMakeLists.txt
@@ -4,6 +4,7 @@ include_directories(
${PCRE_INCLUDE_DIRS}
${JSONC_INCLUDE_DIRS}
${XKBCOMMON_INCLUDE_DIRS}
+ ${LIBINPUT_LIBRARIES}
)
add_executable(sway
@@ -15,6 +16,7 @@ add_executable(sway
extensions.c
focus.c
handlers.c
+ input.c
input_state.c
ipc-server.c
layout.c
@@ -32,6 +34,7 @@ target_link_libraries(sway
${PCRE_LIBRARIES}
${JSONC_LIBRARIES}
${WAYLAND_SERVER_LIBRARIES}
+ ${LIBINPUT_LIBRARIES}
m
)