aboutsummaryrefslogtreecommitdiff
path: root/sway/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'sway/CMakeLists.txt')
-rw-r--r--sway/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/sway/CMakeLists.txt b/sway/CMakeLists.txt
index 5b6104f3..51f27a05 100644
--- a/sway/CMakeLists.txt
+++ b/sway/CMakeLists.txt
@@ -5,6 +5,8 @@ include_directories(
${JSONC_INCLUDE_DIRS}
${XKBCOMMON_INCLUDE_DIRS}
${LIBINPUT_INCLUDE_DIRS}
+ ${CAIRO_INCLUDE_DIRS}
+ ${PANGO_INCLUDE_DIRS}
)
add_executable(sway
@@ -24,6 +26,7 @@ add_executable(sway
output.c
resize.c
workspace.c
+ border.c
)
add_definitions(
@@ -33,12 +36,15 @@ add_definitions(
target_link_libraries(sway
sway-common
sway-protocols
+ sway-wayland
${WLC_LIBRARIES}
${XKBCOMMON_LIBRARIES}
${PCRE_LIBRARIES}
${JSONC_LIBRARIES}
${WAYLAND_SERVER_LIBRARIES}
${LIBINPUT_LIBRARIES}
+ ${PANGO_LIBRARIES}
+ ${JSONC_LIBRARIES}
m
)