aboutsummaryrefslogtreecommitdiff
path: root/sway/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'sway/CMakeLists.txt')
-rw-r--r--sway/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/sway/CMakeLists.txt b/sway/CMakeLists.txt
index 5b6104f3..6c62d676 100644
--- a/sway/CMakeLists.txt
+++ b/sway/CMakeLists.txt
@@ -5,6 +5,8 @@ include_directories(
${JSONC_INCLUDE_DIRS}
${XKBCOMMON_INCLUDE_DIRS}
${LIBINPUT_INCLUDE_DIRS}
+ ${CAIRO_INCLUDE_DIRS}
+ ${PANGO_INCLUDE_DIRS}
)
add_executable(sway
@@ -24,6 +26,7 @@ add_executable(sway
output.c
resize.c
workspace.c
+ render.c
)
add_definitions(
@@ -39,6 +42,8 @@ target_link_libraries(sway
${JSONC_LIBRARIES}
${WAYLAND_SERVER_LIBRARIES}
${LIBINPUT_LIBRARIES}
+ ${PANGO_LIBRARIES}
+ ${JSONC_LIBRARIES}
m
)