aboutsummaryrefslogtreecommitdiff
path: root/protocols/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'protocols/meson.build')
-rw-r--r--protocols/meson.build18
1 files changed, 3 insertions, 15 deletions
diff --git a/protocols/meson.build b/protocols/meson.build
index 73a6fda5..1fda600e 100644
--- a/protocols/meson.build
+++ b/protocols/meson.build
@@ -2,12 +2,6 @@ wl_protocol_dir = wayland_protos.get_pkgconfig_variable('pkgdatadir')
wayland_scanner = find_program('wayland-scanner')
-wayland_scanner_server = generator(
- wayland_scanner,
- output: '@BASENAME@-protocol.h',
- arguments: ['server-header', '@INPUT@', '@OUTPUT@'],
-)
-
wayland_scanner_code = generator(
wayland_scanner,
output: '@BASENAME@-protocol.c',
@@ -20,10 +14,9 @@ wayland_scanner_client = generator(
arguments: ['client-header', '@INPUT@', '@OUTPUT@'],
)
-protocols = []
-
-client_protocols = [
- 'wlr-layer-shell-unstable-v1.xml',
+protocols = [
+ [wl_protocol_dir, 'stable/xdg-shell/xdg-shell.xml'],
+ ['wlr-layer-shell-unstable-v1.xml']
]
wl_protos_src = []
@@ -32,11 +25,6 @@ wl_protos_headers = []
foreach p : protocols
xml = join_paths(p)
wl_protos_src += wayland_scanner_code.process(xml)
- wl_protos_headers += wayland_scanner_server.process(xml)
-endforeach
-
-foreach p : client_protocols
- xml = join_paths(p)
wl_protos_headers += wayland_scanner_client.process(xml)
endforeach