aboutsummaryrefslogtreecommitdiff
path: root/protocols/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'protocols/CMakeLists.txt')
-rw-r--r--protocols/CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/protocols/CMakeLists.txt b/protocols/CMakeLists.txt
new file mode 100644
index 00000000..07becc36
--- /dev/null
+++ b/protocols/CMakeLists.txt
@@ -0,0 +1,22 @@
+include(Wayland)
+
+WAYLAND_ADD_PROTOCOL_CLIENT(proto-client-xdg-shell
+ xdg-shell.xml
+ xdg-shell
+)
+WAYLAND_ADD_PROTOCOL_CLIENT(proto-client-desktop-shell
+ desktop-shell.xml
+ desktop-shell
+)
+WAYLAND_ADD_PROTOCOL_SERVER(proto-server-desktop-shell
+ desktop-shell.xml
+ desktop-shell
+)
+
+add_library(sway-protocols
+ ${proto-client-xdg-shell}
+ ${proto-client-desktop-shell}
+ ${proto-server-desktop-shell}
+ )
+
+set(PROTOCOLS_INCLUDE_DIRS ${CMAKE_BINARY_DIR}/protocols PARENT_SCOPE)