aboutsummaryrefslogtreecommitdiff
path: root/protocols/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'protocols/CMakeLists.txt')
-rw-r--r--protocols/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/protocols/CMakeLists.txt b/protocols/CMakeLists.txt
index d7516d0c..ff0a2e4d 100644
--- a/protocols/CMakeLists.txt
+++ b/protocols/CMakeLists.txt
@@ -22,7 +22,7 @@ WAYLAND_ADD_PROTOCOL_SERVER(proto-server-swaylock
swaylock
)
-add_library(sway-protocols
+add_library(sway-protocols STATIC
${proto-client-xdg-shell}
${proto-client-desktop-shell}
${proto-server-desktop-shell}
@@ -31,3 +31,4 @@ add_library(sway-protocols
)
set(PROTOCOLS_INCLUDE_DIRS ${CMAKE_BINARY_DIR}/protocols PARENT_SCOPE)
+INCLUDE_DIRECTORIES(${WAYLAND_INCLUDE_DIR} ${XKBCOMMON_INCLUDE_DIRS})