aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build11
1 files changed, 11 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 2a020323..0e4b4f21 100644
--- a/meson.build
+++ b/meson.build
@@ -205,3 +205,14 @@ if (get_option('bash_completions'))
install_data(bash_files, install_dir: bash_install_dir)
endif
+
+if (get_option('fish_completions'))
+ fish_files = files(
+ 'completions/fish/sway.fish',
+ 'completions/fish/swaylock.fish',
+ 'completions/fish/swaymsg.fish',
+ )
+ fish_install_dir = datadir + '/fish/completions'
+
+ install_data(fish_files, install_dir: fish_install_dir)
+endif