aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 0c35b0e5..b681f43a 100644
--- a/meson.build
+++ b/meson.build
@@ -38,8 +38,10 @@ math = cc.find_library('m')
git = find_program('git', required: false)
a2x = find_program('a2x', required: false)
+conf_data = configuration_data()
+
if gdk_pixbuf.found()
- add_project_arguments('-DWITH_GDK_PIXBUF', language : 'c')
+ conf_data.set('HAVE_GDK_PIXBUF', true)
endif
if a2x.found()
@@ -92,6 +94,7 @@ add_project_arguments('-DSWAY_VERSION=@0@'.format(version), language: 'c')
sway_inc = include_directories('include')
+subdir('include')
subdir('protocols')
subdir('common')
subdir('sway')