aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 4 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 0d0f7339..766bf012 100644
--- a/meson.build
+++ b/meson.build
@@ -12,6 +12,8 @@ project(
add_project_arguments(
[
+ '-DSWAY_SRC_DIR="@0@"'.format(meson.current_source_dir()),
+
'-DWL_HIDE_DEPRECATED',
'-DWLR_USE_UNSTABLE',
@@ -49,8 +51,8 @@ gdk_pixbuf = dependency('gdk-pixbuf-2.0', required: get_option('gdk-pixbuf')
pixman = dependency('pixman-1')
libevdev = dependency('libevdev')
libinput = dependency('libinput', version: '>=1.6.0')
-systemd = dependency('libsystemd', required: false)
-elogind = dependency('libelogind', required: false)
+systemd = dependency('libsystemd', version: '>=239', required: false)
+elogind = dependency('libelogind', version: '>=239', required: false)
xcb = dependency('xcb', required: get_option('xwayland'))
math = cc.find_library('m')
rt = cc.find_library('rt')