aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build17
1 files changed, 2 insertions, 15 deletions
diff --git a/meson.build b/meson.build
index bb60bc89..810a657e 100644
--- a/meson.build
+++ b/meson.build
@@ -108,13 +108,7 @@ if scdoc.found()
endforeach
endif
-# If prefix is '/usr', sysconfdir will be explicitly set to '/etc' by Meson to
-# enforce FHS compliance, so we should look for configs there as well.
-if prefix == '/usr'
- add_project_arguments('-DSYSCONFDIR="/@0@"'.format(sysconfdir), language : 'c')
-else
- add_project_arguments('-DSYSCONFDIR="/@0@/@1@"'.format(prefix, sysconfdir), language : 'c')
-endif
+add_project_arguments('-DSYSCONFDIR="/@0@"'.format(join_paths(prefix, sysconfdir)), language : 'c')
version = get_option('sway-version')
if version != ''
@@ -159,14 +153,7 @@ subdir('swaylock')
config = configuration_data()
config.set('datadir', join_paths(prefix, datadir))
config.set('prefix', prefix)
-
-# If prefix is '/usr', sysconfdir will be explicitly set to '/etc' by Meson to
-# enforce FHS compliance, so we should look for configs there as well.
-if prefix == '/usr'
- config.set('sysconfdir', sysconfdir)
-else
- config.set('sysconfdir', join_paths(prefix, sysconfdir))
-endif
+config.set('sysconfdir', join_paths(prefix, sysconfdir))
configure_file(
configuration: config,