aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 5 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 57dbea02..bd20ca99 100644
--- a/meson.build
+++ b/meson.build
@@ -19,12 +19,13 @@ is_freebsd = host_machine.system().startswith('freebsd')
datadir = get_option('datadir')
sysconfdir = get_option('sysconfdir')
prefix = get_option('prefix')
-instlibdir = get_option('instlibdir')
+libexecdir = get_option('libexecdir')
-if instlibdir == ''
- instlibdir = join_paths(prefix, 'lib/sway')
+if libexecdir == ''
+ libexecdir = 'lib'
endif
-add_project_arguments('-DINSTLIBDIR="/@0@"'.format(instlibdir), language : 'c')
+sway_libexecdir = join_paths(prefix, libexecdir, 'sway')
+add_project_arguments('-DSWAY_LIBEXECDIR="/@0@"'.format(sway_libexecdir), language : 'c')
jsonc = dependency('json-c', version: '>=0.13')