aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 622769a3..0c35b0e5 100644
--- a/meson.build
+++ b/meson.build
@@ -27,7 +27,10 @@ wayland_client = dependency('wayland-client')
wayland_egl = dependency('wayland-egl')
wayland_protos = dependency('wayland-protocols')
xkbcommon = dependency('xkbcommon')
+cairo = dependency('cairo')
pango = dependency('pango')
+pangocairo = dependency('pangocairo')
+gdk_pixbuf = dependency('gdk-pixbuf-2.0', required: false)
pixman = dependency('pixman-1')
libcap = dependency('libcap')
libinput = dependency('libinput')
@@ -35,6 +38,10 @@ math = cc.find_library('m')
git = find_program('git', required: false)
a2x = find_program('a2x', required: false)
+if gdk_pixbuf.found()
+ add_project_arguments('-DWITH_GDK_PIXBUF', language : 'c')
+endif
+
if a2x.found()
mandir = get_option('mandir')
man_files = [
@@ -89,6 +96,7 @@ subdir('protocols')
subdir('common')
subdir('sway')
subdir('swaymsg')
+subdir('client')
subdir('swaybg')
config = configuration_data()