aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 1d40581a..a2def755 100644
--- a/meson.build
+++ b/meson.build
@@ -48,6 +48,12 @@ git = find_program('git', required: false)
conf_data = configuration_data()
+if get_option('enable-xwayland')
+ conf_data.set('HAVE_XWAYLAND', true)
+else
+ conf_data.set('HAVE_XWAYLAND', false)
+endif
+
if gdk_pixbuf.found()
conf_data.set('HAVE_GDK_PIXBUF', true)
endif