aboutsummaryrefslogtreecommitdiff
path: root/common/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'common/meson.build')
-rw-r--r--common/meson.build23
1 files changed, 23 insertions, 0 deletions
diff --git a/common/meson.build b/common/meson.build
new file mode 100644
index 00000000..44a29508
--- /dev/null
+++ b/common/meson.build
@@ -0,0 +1,23 @@
+lib_sway_common = static_library(
+ 'sway-common',
+ files(
+ 'background-image.c',
+ 'cairo.c',
+ 'ipc-client.c',
+ 'log.c',
+ 'list.c',
+ 'pango.c',
+ 'readline.c',
+ 'stringop.c',
+ 'unicode.c',
+ 'util.c'
+ ),
+ dependencies: [
+ cairo,
+ gdk_pixbuf,
+ pango,
+ pangocairo,
+ wlroots
+ ],
+ include_directories: sway_inc
+)