aboutsummaryrefslogtreecommitdiff
path: root/common/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'common/meson.build')
-rw-r--r--common/meson.build20
1 files changed, 8 insertions, 12 deletions
diff --git a/common/meson.build b/common/meson.build
index 4ad47077..851e7bbf 100644
--- a/common/meson.build
+++ b/common/meson.build
@@ -1,17 +1,7 @@
-deps = [
- cairo,
- pango,
- pangocairo,
- wlroots
-]
-
-if gdk_pixbuf.found()
- deps += [gdk_pixbuf]
-endif
-
lib_sway_common = static_library(
'sway-common',
files(
+ 'background-image.c',
'cairo.c',
'ipc-client.c',
'log.c',
@@ -21,6 +11,12 @@ lib_sway_common = static_library(
'stringop.c',
'util.c'
),
- dependencies: deps,
+ dependencies: [
+ cairo,
+ gdk_pixbuf,
+ pango,
+ pangocairo,
+ wlroots
+ ],
include_directories: sway_inc
)