aboutsummaryrefslogtreecommitdiff
path: root/common/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'common/meson.build')
-rw-r--r--common/meson.build21
1 files changed, 16 insertions, 5 deletions
diff --git a/common/meson.build b/common/meson.build
index abe0cdcf..01736ca6 100644
--- a/common/meson.build
+++ b/common/meson.build
@@ -1,12 +1,23 @@
-lib_sway_common = static_library('sway-common',
+deps = [
+ cairo,
+ wlroots
+]
+
+if gdk_pixbuf.found()
+ deps += [gdk_pixbuf]
+endif
+
+lib_sway_common = static_library(
+ 'sway-common',
files(
+ 'cairo.c',
+ 'ipc-client.c',
'log.c',
'list.c',
- 'util.c',
- 'stringop.c',
'readline.c',
- 'ipc-client.c'
+ 'stringop.c',
+ 'util.c'
),
- dependencies: [ wlroots ],
+ dependencies: deps,
include_directories: sway_inc
)