aboutsummaryrefslogtreecommitdiff
path: root/client/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'client/meson.build')
-rw-r--r--client/meson.build23
1 files changed, 9 insertions, 14 deletions
diff --git a/client/meson.build b/client/meson.build
index 597899ce..2bdda457 100644
--- a/client/meson.build
+++ b/client/meson.build
@@ -1,21 +1,16 @@
-deps = [
- cairo,
- pango,
- pangocairo,
- wlroots,
- wayland_client,
-]
-
-if gdk_pixbuf.found()
- deps += [gdk_pixbuf]
-endif
-
lib_sway_client = static_library(
'sway-client',
files(
- 'buffer-pool.c',
+ 'pool-buffer.c',
),
- dependencies: deps,
+ dependencies: [
+ cairo,
+ gdk_pixbuf,
+ pango,
+ pangocairo,
+ wlroots,
+ wayland_client,
+ ],
link_with: [lib_sway_common],
include_directories: sway_inc
)