aboutsummaryrefslogtreecommitdiff
path: root/client/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'client/meson.build')
-rw-r--r--client/meson.build21
1 files changed, 21 insertions, 0 deletions
diff --git a/client/meson.build b/client/meson.build
new file mode 100644
index 00000000..597899ce
--- /dev/null
+++ b/client/meson.build
@@ -0,0 +1,21 @@
+deps = [
+ cairo,
+ pango,
+ pangocairo,
+ wlroots,
+ wayland_client,
+]
+
+if gdk_pixbuf.found()
+ deps += [gdk_pixbuf]
+endif
+
+lib_sway_client = static_library(
+ 'sway-client',
+ files(
+ 'buffer-pool.c',
+ ),
+ dependencies: deps,
+ link_with: [lib_sway_common],
+ include_directories: sway_inc
+)