aboutsummaryrefslogtreecommitdiff
path: root/client/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'client/meson.build')
-rw-r--r--client/meson.build16
1 files changed, 16 insertions, 0 deletions
diff --git a/client/meson.build b/client/meson.build
new file mode 100644
index 00000000..2bdda457
--- /dev/null
+++ b/client/meson.build
@@ -0,0 +1,16 @@
+lib_sway_client = static_library(
+ 'sway-client',
+ files(
+ 'pool-buffer.c',
+ ),
+ dependencies: [
+ cairo,
+ gdk_pixbuf,
+ pango,
+ pangocairo,
+ wlroots,
+ wayland_client,
+ ],
+ link_with: [lib_sway_common],
+ include_directories: sway_inc
+)