aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 587c3dac..c63a88c7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -45,6 +45,7 @@ option(enable-swaygrab "Enables the swaygrab utility" YES)
option(enable-swaymsg "Enables the swaymsg utility" YES)
option(enable-gdk-pixbuf "Use Pixbuf to support more image formats" YES)
option(enable-binding-event "Enables binding event subscription" YES)
+option(zsh-completions "Zsh shell completions" YES)
option(default-wallpaper "Installs the default wallpaper" YES)
find_package(JsonC REQUIRED)
@@ -117,7 +118,9 @@ if(enable-swaylock)
message(WARNING "Not building swaylock - cairo, pango, and PAM are required.")
endif()
endif()
-
+if(zsh-completions)
+ add_subdirectory(completions/zsh)
+endif()
install(
FILES ${CMAKE_CURRENT_SOURCE_DIR}/sway.desktop
DESTINATION share/wayland-sessions