aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9c556b0e..447fd584 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -44,6 +44,7 @@ option(enable-swaybar "Enables the swaybar utility" YES)
option(enable-swaygrab "Enables the swaygrab utility" YES)
option(enable-swaymsg "Enables the swaymsg utility" YES)
option(enable-gdk-pixbuf "Use Pixbuf to support more image formats" YES)
+option(enable-binding-event "Enables binding event subscription" YES)
find_package(JsonC REQUIRED)
find_package(PCRE REQUIRED)
@@ -112,6 +113,9 @@ if(enable-swaylock)
message(WARNING "Not building swaylock - cairo, pango, and PAM are required.")
endif()
endif()
+if(enable-binding-event)
+ add_definitions(-DSWAY_BINDING_EVENT=1)
+endif()
install(
FILES ${CMAKE_CURRENT_SOURCE_DIR}/sway.desktop