aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1298a2ce..9e1e1dde 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,6 +2,9 @@ cmake_minimum_required(VERSION 3.1.0)
project(sway C)
+set(FALLBACK_CONFIG_DIR "/etc/sway/")
+add_definitions('-DFALLBACK_CONFIG_DIR=\"${FALLBACK_CONFIG_DIR}\"')
+
set(CMAKE_C_FLAGS "-g")
set(CMAKE_C_STANDARD 99)
SET(CMAKE_C_EXTENSIONS OFF)
@@ -80,7 +83,7 @@ install(
COMPONENT runtime)
install(
FILES "${CMAKE_CURRENT_SOURCE_DIR}/config"
- DESTINATION /etc/sway/
+ DESTINATION "${FALLBACK_CONFIG_DIR}"
COMPONENT configuration)
add_custom_target(man ALL)