aboutsummaryrefslogtreecommitdiff
path: root/swaynag/meson.build
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2018-08-02 09:28:13 -0400
committerGitHub <noreply@github.com>2018-08-02 09:28:13 -0400
commitea14ef40955a94e21a5198d2469e54fe1e6056e5 (patch)
tree1a28ee032b762f471917c1f175ba02500f9ef794 /swaynag/meson.build
parent9aa258d33a9baa42895214da7e82f4568fcb8f76 (diff)
parent706c0fbe2376e15f8140be60f3c8b0713128ebba (diff)
Merge pull request #2366 from RedSoxFan/nagbar
Implement swaynag
Diffstat (limited to 'swaynag/meson.build')
-rw-r--r--swaynag/meson.build23
1 files changed, 23 insertions, 0 deletions
diff --git a/swaynag/meson.build b/swaynag/meson.build
new file mode 100644
index 00000000..2ba3ed95
--- /dev/null
+++ b/swaynag/meson.build
@@ -0,0 +1,23 @@
+executable(
+ 'swaynag', [
+ 'config.c',
+ 'main.c',
+ 'render.c',
+ 'swaynag.c',
+ 'types.c',
+ ],
+ include_directories: [sway_inc],
+ dependencies: [
+ cairo,
+ client_protos,
+ gdk_pixbuf,
+ math,
+ pango,
+ pangocairo,
+ wayland_client,
+ wayland_cursor,
+ wlroots,
+ ],
+ link_with: [lib_sway_common, lib_sway_client],
+ install: true
+)