aboutsummaryrefslogtreecommitdiff
path: root/swaymsg/meson.build
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2017-12-01 08:21:01 -0500
committerGitHub <noreply@github.com>2017-12-01 08:21:01 -0500
commit1cfebe827ae53a243ffdd1e09f8b71d4c1a4e254 (patch)
treeb74002984ff80201c02ed9c22ca2fe1cdae98e23 /swaymsg/meson.build
parent1fbcd097ae2841b5f8f56cf67c1e94605deb0d25 (diff)
parent3546412fc9fb9a51b4316070eff4991c14594127 (diff)
Merge pull request #1479 from acrisci/feature/meson-build
meson build
Diffstat (limited to 'swaymsg/meson.build')
-rw-r--r--swaymsg/meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/swaymsg/meson.build b/swaymsg/meson.build
new file mode 100644
index 00000000..2d678878
--- /dev/null
+++ b/swaymsg/meson.build
@@ -0,0 +1,8 @@
+executable(
+ 'swaymsg',
+ 'main.c',
+ include_directories: [sway_inc],
+ dependencies: [jsonc],
+ link_with: [lib_sway_common],
+ install: true
+)