aboutsummaryrefslogtreecommitdiff
path: root/swaylock/meson.build
diff options
context:
space:
mode:
authoremersion <contact@emersion.fr>2019-01-14 08:57:20 +0100
committerGitHub <noreply@github.com>2019-01-14 08:57:20 +0100
commit89ad3f2bbbb6f5f367387992eea5d5c6f7fa7642 (patch)
tree2ef2485e9a103b9850219b7cf6375e48b20b72b5 /swaylock/meson.build
parent784178ed374e0cf94541a352b2407708c89c6d7c (diff)
parent3fca8b8d22ee51a934fa3b8704c5aee8a5de7689 (diff)
Merge pull request #3417 from swaywm/remove-swaylock
Split swaylock into separate project
Diffstat (limited to 'swaylock/meson.build')
-rw-r--r--swaylock/meson.build55
1 files changed, 0 insertions, 55 deletions
diff --git a/swaylock/meson.build b/swaylock/meson.build
deleted file mode 100644
index f3321a78..00000000
--- a/swaylock/meson.build
+++ /dev/null
@@ -1,55 +0,0 @@
-sysconfdir = get_option('sysconfdir')
-
-dependencies = [
- cairo,
- client_protos,
- gdk_pixbuf,
- math,
- pango,
- pangocairo,
- xkbcommon,
- wayland_client,
- wlroots,
-]
-
-sources = [
- 'main.c',
- 'password.c',
- 'render.c',
- 'seat.c'
-]
-
-if libpam.found()
- sources += ['pam.c']
- dependencies += [libpam]
-else
- warning('The swaylock binary must be setuid when compiled without libpam')
- warning('You must do this manually post-install: chmod a+s /path/to/swaylock')
- sources += ['shadow.c']
- if crypt.found()
- dependencies += [crypt]
- endif
-endif
-
-executable('swaylock',
- sources,
- include_directories: [sway_inc],
- dependencies: dependencies,
- link_with: [lib_sway_common, lib_sway_client],
- install_rpath : rpathdir,
- install: true
-)
-
-if is_freebsd
- install_data(
- 'pam/swaylock.freebsd',
- install_dir: sysconfdir + '/pam.d/',
- rename: 'swaylock'
- )
-else
- install_data(
- 'pam/swaylock.linux',
- install_dir: sysconfdir + '/pam.d/',
- rename: 'swaylock'
- )
-endif