aboutsummaryrefslogtreecommitdiff
path: root/swaylock/meson.build
diff options
context:
space:
mode:
authoremersion <contact@emersion.fr>2018-10-06 18:47:34 +0200
committerGitHub <noreply@github.com>2018-10-06 18:47:34 +0200
commit176832fe30576ccfbb7dee3d9e600e56abf21da1 (patch)
treea4ccf0cb0afafc0c8db6cbded85a3b156945b12b /swaylock/meson.build
parent85961f63bfe922831011f75860b3acde3d890a9f (diff)
parentc89e00a97e6bb04c6b4b5c906befdb4767540dbe (diff)
Merge pull request #2776 from swaywm/swaylock-setuid
Fix swaylock w/shadow on glibc, improve security
Diffstat (limited to 'swaylock/meson.build')
-rw-r--r--swaylock/meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/swaylock/meson.build b/swaylock/meson.build
index 6605340b..f3321a78 100644
--- a/swaylock/meson.build
+++ b/swaylock/meson.build
@@ -26,6 +26,9 @@ else
warning('The swaylock binary must be setuid when compiled without libpam')
warning('You must do this manually post-install: chmod a+s /path/to/swaylock')
sources += ['shadow.c']
+ if crypt.found()
+ dependencies += [crypt]
+ endif
endif
executable('swaylock',