aboutsummaryrefslogtreecommitdiff
path: root/swayidle/meson.build
diff options
context:
space:
mode:
authorMattias Eriksson <snaggen@mayam.com>2018-04-17 09:54:02 +0200
committerMattias Eriksson <snaggen@mayam.com>2018-05-13 00:30:09 +0200
commit8fbafbfab5671d56dd469f2205b7906c4a7f7c7c (patch)
treeab4eab0020d97dc5091b72479c383989ccc84729 /swayidle/meson.build
parent9d607b72532096e469fdaccf474836c310b629ff (diff)
Idle handling for dpms/lockscreen et al
Swayidle handles idle events and allows for dpms and lockscreen handling. It also handles systemd sleep events, and can raise a lockscreen on sleep Fixes #541
Diffstat (limited to 'swayidle/meson.build')
-rw-r--r--swayidle/meson.build17
1 files changed, 17 insertions, 0 deletions
diff --git a/swayidle/meson.build b/swayidle/meson.build
new file mode 100644
index 00000000..09c482d6
--- /dev/null
+++ b/swayidle/meson.build
@@ -0,0 +1,17 @@
+threads = dependency('threads')
+
+executable(
+ 'swayidle', [
+ 'main.c',
+ ],
+ include_directories: [sway_inc],
+ dependencies: [
+ client_protos,
+ wayland_client,
+ wayland_server,
+ wlroots,
+ swayidle_deps,
+ ],
+ link_with: [lib_sway_common, lib_sway_client],
+ install: true
+)