aboutsummaryrefslogtreecommitdiff
path: root/swayidle/meson.build
diff options
context:
space:
mode:
authorBrian Ashworth <RedSoxFan@users.noreply.github.com>2018-05-14 00:28:21 -0400
committerGitHub <noreply@github.com>2018-05-14 00:28:21 -0400
commit34b864fb1752fde2528db6aa86d53c23412a8f43 (patch)
treeb387f1e1eb8f8fc16faeb4bf24a0ab6e8ba5787c /swayidle/meson.build
parent6ff7c5273659061ec4ff2f6c79c69af2d4d165a5 (diff)
parent270c1ee7e507f1d2960920a7f4f0cc70f4e13d26 (diff)
Merge branch 'master' into fix-1975
Diffstat (limited to 'swayidle/meson.build')
-rw-r--r--swayidle/meson.build18
1 files changed, 18 insertions, 0 deletions
diff --git a/swayidle/meson.build b/swayidle/meson.build
new file mode 100644
index 00000000..f62545f8
--- /dev/null
+++ b/swayidle/meson.build
@@ -0,0 +1,18 @@
+threads = dependency('threads')
+
+executable(
+ 'swayidle', [
+ 'main.c',
+ ],
+ include_directories: [sway_inc],
+ dependencies: [
+ client_protos,
+ pixman,
+ wayland_client,
+ wayland_server,
+ wlroots,
+ swayidle_deps,
+ ],
+ link_with: [lib_sway_common, lib_sway_client],
+ install: true
+)