aboutsummaryrefslogtreecommitdiff
path: root/swaygrab/CMakeLists.txt
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2015-12-02 05:34:18 -0500
committerDrew DeVault <sir@cmpwn.com>2015-12-02 05:34:18 -0500
commit7a1c8c2939c8581bb47323513b91a94aebf62b36 (patch)
tree717052d8d88f3fd14d26566daa520dbdd3a452fe /swaygrab/CMakeLists.txt
parentf76b7f5385f79f9e004a096ed4896725cac30f9c (diff)
parentcce9c338c07e889aa82db806f0dddf2f997edbb6 (diff)
Merge pull request #291 from christophgysin/libs
cmake: build common code only once
Diffstat (limited to 'swaygrab/CMakeLists.txt')
-rw-r--r--swaygrab/CMakeLists.txt7
1 files changed, 2 insertions, 5 deletions
diff --git a/swaygrab/CMakeLists.txt b/swaygrab/CMakeLists.txt
index 77d96412..d5468cda 100644
--- a/swaygrab/CMakeLists.txt
+++ b/swaygrab/CMakeLists.txt
@@ -1,12 +1,9 @@
-file(GLOB sources *.c)
-file(GLOB common ../common/*.c)
-
add_executable(swaygrab
- ${sources}
- ${common}
+ main.c
)
target_link_libraries(swaygrab
+ sway-common
rt
)