aboutsummaryrefslogtreecommitdiff
path: root/swaybar/meson.build
diff options
context:
space:
mode:
authorIan Fan <ianfan0@gmail.com>2018-10-28 10:25:47 +0000
committerIan Fan <ianfan0@gmail.com>2018-12-31 20:40:18 +0000
commit5f65f339896fadf0011b75d78c869594876d35d9 (patch)
treebbb234ad123657f1a8ed1f311cf9183b67e7e961 /swaybar/meson.build
parent598e950296ce9fef24b54b4c01302ee68473fb8a (diff)
swaybar: add tray interface
Diffstat (limited to 'swaybar/meson.build')
-rw-r--r--swaybar/meson.build40
1 files changed, 27 insertions, 13 deletions
diff --git a/swaybar/meson.build b/swaybar/meson.build
index c27cf2c2..b83f47e5 100644
--- a/swaybar/meson.build
+++ b/swaybar/meson.build
@@ -1,3 +1,28 @@
+tray_files = get_option('enable-tray') ? [
+ 'tray/tray.c',
+] : []
+
+swaybar_deps = [
+ cairo,
+ client_protos,
+ gdk_pixbuf,
+ jsonc,
+ math,
+ pango,
+ pangocairo,
+ rt,
+ wayland_client,
+ wayland_cursor,
+ wlroots,
+]
+if get_option('enable-tray')
+ if systemd.found()
+ swaybar_deps += systemd
+ elif elogind.found()
+ swaybar_deps += elogind
+ endif
+endif
+
executable(
'swaybar', [
'bar.c',
@@ -8,21 +33,10 @@ executable(
'main.c',
'render.c',
'status_line.c',
+ tray_files
],
include_directories: [sway_inc],
- dependencies: [
- cairo,
- client_protos,
- gdk_pixbuf,
- jsonc,
- math,
- pango,
- pangocairo,
- rt,
- wayland_client,
- wayland_cursor,
- wlroots,
- ],
+ dependencies: swaybar_deps,
link_with: [lib_sway_common, lib_sway_client],
install_rpath : rpathdir,
install: true