aboutsummaryrefslogtreecommitdiff
path: root/sway/meson.build
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2018-07-25 08:27:40 -0400
committerGitHub <noreply@github.com>2018-07-25 08:27:40 -0400
commitfc718f629af231f8a0ae795b2f7529e213cab183 (patch)
tree7917aadbfb09d02d3d60045f0ba8d5028f0c4bb4 /sway/meson.build
parentfd1e2c172c12b5c5a3adac8e6de4009697bd7567 (diff)
parent384c55c0b465d6b9a9c4cb88d8752435ac5cf708 (diff)
downloadsway-fc718f629af231f8a0ae795b2f7529e213cab183.tar.xz
Merge pull request #2350 from ppascher/xwayland-optional
Added meson option to allow building sway without xwayland support
Diffstat (limited to 'sway/meson.build')
-rw-r--r--sway/meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/sway/meson.build b/sway/meson.build
index 30c848e2..649a3ac2 100644
--- a/sway/meson.build
+++ b/sway/meson.build
@@ -18,7 +18,6 @@ sway_sources = files(
'desktop/transaction.c',
'desktop/xdg_shell_v6.c',
'desktop/xdg_shell.c',
- 'desktop/xwayland.c',
'input/input-manager.c',
'input/seat.c',
@@ -152,6 +151,10 @@ sway_sources = files(
'tree/output.c',
)
+if get_option('enable-xwayland')
+ sway_sources += 'desktop/xwayland.c'
+endif
+
sway_deps = [
cairo,
gdk_pixbuf,